ChromeRiver Website Down
Incident Report for SeattleU IT Services
Resolved
This incident has been resolved.
Posted Mar 18, 2024 - 13:44 PDT
Investigating
We have reports that our ChromeRiver links do not appear to be working. The vendor website is currently not operational. We are engaging with their support team to understand the nature and estimated length of the outage.
Posted Mar 18, 2024 - 11:23 PDT
This incident affected: Other.