Microsoft reports as of about 12pm today that the issue has been resolved.
Posted Nov 26, 2024 - 13:27 PST
Update
Microsoft is conducting additional optimizations to further improve service ability, which remains healthy. They are closing in on a full mitigation to address any remaining impact, and they are closely monitoring to ensure the trend continues.
Posted Nov 26, 2024 - 08:46 PST
Monitoring
Microsoft reports they are showing signs of restoration upwards of 90% recovery with their resolution, which they will continue to roll out to their remaining affected services and users.
Posted Nov 25, 2024 - 13:30 PST
Update
Microsoft is continuing to work to resolve the ongoing issues. ITS will send another update once we hear more information.
Posted Nov 25, 2024 - 11:42 PST
Identified
Microsoft has reported issues with the Microsoft 365 Suite of services including Exchange Online, SharePoint Online, Microsoft Teams. ITS will post more as Microsoft shares more but users may be unable to access or use some Microsoft 365 services and features.