Colleague, MySeattleU, InformSU and SU Forms are Operational.
Incident Report for SeattleU IT Services
Resolved
This incident has been resolved. Please contact the Service Desk or file a ticket online if any issues arise.
Posted Jul 22, 2024 - 08:02 PDT
Monitoring
All systems are now operational. We expect some systems will need up to 24 hours for all data to be fully synchronized. We will continue to monitor the situation to ensure all issues are resolved.
Posted Jul 19, 2024 - 19:48 PDT
Update
Colleague and MySeattleU are now fully operational. A related database is still offline and will continue to affect InformSU, SU Forms, and data integrations across our partner products. We are continuing to engage with our vendor to resolve all issues.
Posted Jul 19, 2024 - 16:34 PDT
Update
We are seeing that mySeattleu is available again, but some data retrieval in the system may be slow. Colleague UI remains unavailable as we await restoration of service by Ellucian, our vendor partner. This means that services that rely on Colleague data such as ProcureSU, SU Forms, and InformSU continue to be affected. We have heard from TouchNet, our Student Account Center vendor for billing and payments, that issues with ACH processing have been resolved.

We appreciate everyone's patience and understanding of the CrowdStrike issue's impact globally and locally on Seattle University. We will post an update in an hour. Thank you!
Posted Jul 19, 2024 - 15:35 PDT
Update
We are continuing to address the issue with our vendor. Colleague is partially working but it is not fully restored.

PLEASE REFRAIN FROM LOGGING INTO COLLEAGUE AT THIS TIME.

The system is not operating as expected and any process that is run may result in data loss or further instability in the system.

MySeattleU and related databases remain unavailable.
Posted Jul 19, 2024 - 13:22 PDT
Identified
We are continuing to identify downstream systems that are partially affected by the database and integration outages.
Posted Jul 19, 2024 - 08:32 PDT
Update
We are continuing to investigate this issue.
Posted Jul 19, 2024 - 08:20 PDT
Update
We are continuing to investigate this issue.
Posted Jul 19, 2024 - 07:20 PDT
Investigating
We are currently experience a complete outage of Colleague, MySeattleU, and our related databases which handle certain operational reports and our data integrations. We expect that this is due to the CrowdStrike issues that occurred overnight. We are working closely with our vendor to address the issue.
Posted Jul 19, 2024 - 07:20 PDT
This incident affected: Colleague, InformSU, mySeattleU, and SU Forms.