LeapFrog/CLSS Course Scheduling Software Down
Incident Report for SeattleU IT Services
Resolved
The issue was resolved after a DNS update.
Posted Dec 02, 2024 - 10:44 PST
Investigating
We are currently investigating the cause of the issue with our vendor.
Posted Dec 02, 2024 - 09:27 PST
This incident affected: Other.