mySeattleU Functions Unavailable
Incident Report for SeattleU IT Services
Resolved
We believe this issue is now resolved, and that services should be working as expected. If you encounter any further issues, please contact the IT Service Desk at servicedesk@seattleu.edu or 206-296-5571. Thank you, and have a great day!
Posted Jan 31, 2023 - 10:57 PST
Identified
We have been able to restore services, but this issue is still being worked, so there may be intermittent outages until the problem is fully resolved. We will provide updates as we have them and appreciate your patience as this work progresses.
Posted Jan 31, 2023 - 08:47 PST
Investigating
We are seeing the same issue occurring with mySeattleU as yesterday where the service is available but the functions within it are not. We have alerted Ellucian, the vendor, and will work to resolve this issue. We are aware that today is the deadline for submitting time for this pay period, so we are acting with the greatest urgency in this matter. Thank you for your patience.
Posted Jan 31, 2023 - 08:16 PST
This incident affected: mySeattleU.