mySeattleU Issue Displaying Information
Incident Report for SeattleU IT Services
Resolved
We have worked with the vendor and identified and resolved the root cause of the issue. We apologize for any inconvenience this may have caused. If you encounter further issues, please contact the IT Service Desk at servicedesk@seattleu.edu or 206-296-5579. Thank you, and have a good night!
Posted Jan 30, 2023 - 20:24 PST
Investigating
The previous issue with mySeattleU has surfaced again. Users can sign into the service, but functions are not displaying needed information. We will continue to work with the vendor to restore service (and hopefully keep it restored). Thank you for your patience.
Posted Jan 30, 2023 - 17:19 PST
This incident affected: mySeattleU.